home Forums # Technical Support Compiling error with visual studio 2013 (platform toolset v120)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2015

    Thank you very much for the FuzzyLite library!

    I have integrated your library in my win32 project. I have copy paste your c++ example in my source. I can compile it under visual studio 2013 without problem then run my executable with your dll but i get read/write memory acces errors. In debug mode, there is no error so i can not found any error.

    I also try the Free Fuzzy Logic library and i have no problem but this c++ library is too basic.

    I have tried to compile the fuzzylite library in visual studio 2013 so i run C:\fuzzylite-5.0\fuzzylite>build.bat from the Visual Studio Terminal x86 but i get :

    NMAKE : fatal error U1064: MAKEFILE introuvable et aucune cible spécifiée
    I have tried cmake then nmake:
    C:\fuzzylite-5.0\fuzzylite>cmake . -G “NMake Makefiles”
    CMake Warning (dev) at CMakeLists.txt:65 (if):
    Policy CMP0054 is not set: Only interpret if() arguments as variables or
    keywords when unquoted. Run “cmake –help-policy CMP0054” for policy
    details. Use the cmake_policy command to set the policy and suppress this

    Quoted variables like “MSVC” will no longer be dereferenced when the policy
    is set to NEW. Since the policy is not set the OLD behavior will be used.
    This warning is for project developers. Use -Wno-dev to suppress it.

    fuzzylite v.5.0b1408


    — Configuring done
    — Generating done
    — Build files have been written to: C:/fuzzylite-5.0/fuzzylite

    but i have errors with this command:
    C:\fuzzylite-5.0\fuzzylite>nmake /f makefile

    C:\fuzzylite-5.0\fuzzylite\.\fl/defuzzifier/Defuzzifier.h(44) : error C2610: ‘fl::Defuzzifier::Defuzzifier(fl::Defuzzifier &&)’ : n’est pas une fonction membre spéciale qui peut être définie par défaut

    with FL_CPP11 at OFF, i have the same errors

    Can you tell me why this error is coming from compiling with build.bat or nmake?

    Thanks for your help !



    i can generate project files with this command :
    cmake . -G “Visual Studio 12 2013”

    I can compile if i replace std::max by std::fmax and if i replace this line in FclImporter.cpp:
    ex << “[syntax error] expected property of type ‘start .. end’, ”
    << “but found <” << range << “> in line: ” << line;
    by this:
    ex << “[syntax error] expected property of type ‘start .. end’, ”
    << “but found <” << range.str() << “> in line: ” << line;


    My project work with my new dll compiled with visual studio 2013 (platform toolset v120)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.