home Forums # Technical Support Using Fuzzy Lite with IDE

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #947


    I am trying to use fuzzy lite on an embedded system (Pic32 Microcontroller) but I can’t get it to compile in
    the microcontroller’s IDE (MPLab). I think the problem lies with including the header files into the project.
    I have added the header files to the path
    along with #include <FL_HEADERS> but it still doesn’t compile.
    Is there anyone who has a similar problem, or does anybody have advice on what I need to learn about to overcome

    Kind Regards,


    Hi Scott,

    please, do not use FL_HEADERS because it is a file only for CMake.

    You need to use #include <fl/Headers.h>

    Let me know if this helps.



    Thanks, that solved the problem I was having. Unfortunately, I’m still having trouble compiling the program
    because it is not recognizing <ostream> or the other #include h files within fuzzylite.h. This is probably to do
    with my IDE not finding these h files on my system. Do you have any recommendations?



    What IDE are you using? Indeed, the problem you are having for is basic configuration issues of your IDE or probably missing headers in your operating system. What OS are you using?

    As for fuzzylite, you must add “/path/to/fuzzylite” in your INCLUDE_PATH in order to find the headers.



    I am using MPLab which is the IDE for pic32. The problem was that this IDE only works with C and not C++ so libraries are missing. I will be able to use fuzzy lite for visualization and debugging but will most likely code the control system in C.

    Thank you for your help



    I think the best option you have is to configure MPLab looking at the configuration of a well-configured IDE. I am guessing you need to add the path to the C++/STL headers in the INCLUDE_PATH and the path to the C++ libraries in the LIBRARY_PATH. Please, look in your filesystem where the header is located and add its path to the INCLUDE_PATH. Once it compiles most of the files, it will probably fail at link time due to the missing libraries, for which you will need to find out which are those libraries and add them to the project as -llibrary-name (e.g. -lfuzzylite). I think my best suggestion is to first configure a simple project to work with fuzzylite using a regular IDE (Netbeans, Eclipse, XCode or Visual Studio), and once you are able to build and run an example, explore the necessary configuration of the IDE to make it work in MPLab.

    Once you manage to make it work, we would all appreciate if you could put detailed information about configuring MPLab to run fuzzylite.



    When I solve the problem, I will be sure to leave the solution up here.

    Thanks again for your detailed instructions


    thanks we will keep contact

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.